Commit b0fefd04 authored by Wit, Allard de's avatar Wit, Allard de
Browse files

Fixed a few problems in the grompy.DataAccessProvider

bumped to version 1.1.1
parent b040846d
......@@ -7,4 +7,4 @@ from .dap import DataAccessProvider
from .cmd import cli
__version__ = "1.1.0"
\ No newline at end of file
__version__ = "1.1.1"
\ No newline at end of file
......@@ -36,7 +36,7 @@ class DataAccessProvider:
self.datasets_enabled = set(self.datasets)
# Build connection to parcel info
self.engine = sa.create_engine(self.parcel_dsn)
self.engine = open_DB_connection(grompy_yaml, self.parcel_dsn)
meta = sa.MetaData(self.engine)
self.tbl_perc_info = sa.Table(self.parcel_table, meta, autoload=True)
self.limit = int(1e9) if limit is None else limit
......@@ -68,7 +68,7 @@ class DataAccessProvider:
"""Enables a dataset for reading with grompy..
"""
if dataset in self.datasets:
self.datasets_enabled.update(dataset)
self.datasets_enabled.add(dataset)
else:
print(f"'{dataset}' unknown, should be one of: {self.datasets}")
......
This diff is collapsed.
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment